[bug #58095] error setting efuse on atmega328pb variant

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #58095] error setting efuse on atmega328pb variant

Kevin Cuzner-2
URL:
  <https://savannah.nongnu.org/bugs/?58095>

                 Summary: error setting efuse on atmega328pb variant
                 Project: AVR Downloader/UploaDEr
            Submitted by: None
            Submitted on: Wed 01 Apr 2020 06:08:58 PM UTC
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: bob
        Originator Email: [hidden email]
             Open/Closed: Open
                 Release: 6.3
         Discussion Lock: Any
     Programmer hardware: usbasp
             Device type: m328pb

    _______________________________________________________

Details:

When programming the atmega328pb I was unable to read efuse and therefore not
sure if I was able to write to it. The value I tried to write was not reported
back correctly.

Solution was to add a 'size = 1;' line to the m328pb's efuse setting in
avrdude.conf file.





    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?58095>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/


Reply | Threaded
Open this post in threaded view
|

[bug #58095] error setting efuse on atmega328pb variant

Kevin Cuzner-2
Update of bug #58095 (project avrdude):

                  Status:                    None => Fixed                  
             Assigned to:                    None => joerg_wunsch          
             Open/Closed:                    Open => Closed                

    _______________________________________________________

Follow-up Comment #1:

Well, until I applied patch #9811 a couple of days ago, avrdude.conf.in didn't
have an "official" ATmega328PB entry at all.

I just verified, the entry that is added now correctly specifies the size=1
parameter.

    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?58095>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/