[bug #57169] MEGA32U2 mEDBG programmer on the ATtiny817 board does not work

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #57169] MEGA32U2 mEDBG programmer on the ATtiny817 board does not work

Kevin Cuzner-2
URL:
  <https://savannah.nongnu.org/bugs/?57169>

                 Summary: MEGA32U2 mEDBG programmer on the ATtiny817 board
does not work
                 Project: AVR Downloader/UploaDEr
            Submitted by: taavi
            Submitted on: Tue 05 Nov 2019 12:13:00 AM UTC
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: taavi
        Originator Email:
             Open/Closed: Open
                 Release: SVN snapshot
         Discussion Lock: Any
     Programmer hardware: ATMEL mEDBG CMSIS-DAP
             Device type: ATtiny817

    _______________________________________________________

Details:

I built the latest version with this summary:

```
Configuration summary:
----------------------
DO HAVE    libelf
DON'T HAVE libusb
DO HAVE    libusb_1_0
DO HAVE    libftdi1
DON'T HAVE libftdi
DON'T HAVE libhid
DO HAVE    libhidapi
DO HAVE    pthread
DISABLED   doc
ENABLED    parport
DISABLED   linuxgpio
ENABLED    linuxspi
```

When I issue `./avrdude -p t817 -c xplainedmini_updi -C /etc/avrdude.conf`
then it errors out with:

```
avrdude: jtag3_edbg_recv(): Inconsistent fragment number; expect 1, got 0

avrdude done.  Thank you.
```

Similar issue by someone else on avrfreaks forum:
https://www.avrfreaks.net/forum/xplained-nano-medbg-no-connection

Please let me know if I can provide some other information that would help
resolve this issue.





    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?57169>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/


Reply | Threaded
Open this post in threaded view
|

[bug #57169] MEGA32U2 mEDBG programmer on the ATtiny817 board does not work

Kevin Cuzner-2
Follow-up Comment #1, bug #57169 (project avrdude):

I forgot to specify that it's the ATtiny817 Xplained mini board (from Atmel by
markings) that has the issue.

    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?57169>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/