[bug #53180] missing programmer or bad -P option argument doesn't result in error message

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[bug #53180] missing programmer or bad -P option argument doesn't result in error message

Joerg Wunsch-6
URL:
  <http://savannah.nongnu.org/bugs/?53180>

                 Summary: missing programmer or bad -P option argument doesn't
result in error message
                 Project: AVR Downloader/UploaDEr
            Submitted by: None
            Submitted on: Sat 17 Feb 2018 10:59:23 PM UTC
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Britton Kerin
        Originator Email: [hidden email]
             Open/Closed: Open
                 Release: 6.3
         Discussion Lock: Any
     Programmer hardware: AVR ISPmkII
             Device type: Mega 328P

    _______________________________________________________

Details:

This command:

  avrdude -c avrispmkII -p m328p -P usb:090200198577 -U hfuse:r:-:h

issued when there is no avrispmkII connected, yields only this message on
stderr:

  avrdude done.  Thank you.

avrdude does exit with a non-zero code in this case, but it should also be
able to give an informative error message.

This command:

  avrdude -c avrispmkII -p m328p -P usb:090200198577 -U hfuse:r:-:h

issued when there is no avrispmkII with serial number 090200198577 connected,
does the same thing.





    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?53180>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev