[bug #49376] Resource busy error on El Capitan

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #49376] Resource busy error on El Capitan

Joerg Wunsch-6
URL:
  <http://savannah.nongnu.org/bugs/?49376>

                 Summary: Resource busy error on El Capitan
                 Project: AVR Downloader/UploaDEr
            Submitted by: None
            Submitted on: Mon Oct 17 20:33:00 2016
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Serjio
        Originator Email: [hidden email]
             Open/Closed: Open
                 Release: 6.3
         Discussion Lock: Any
     Programmer hardware:
             Device type:

    _______________________________________________________

Details:

Tested on two laptops with El Capitan with the same error. Works smoothly on
Yosemite.

avrdude -c stk500v2 -P /dev/cu.usbmodemavrdope1 -p  attiny85
avrdude: ser_open(): can't open device "/dev/cu.usbmodemavrdope1": Resource
busy




    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?49376>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #49376] Resource busy error on El Capitan

Joerg Wunsch-6
Follow-up Comment #1, bug #49376 (project avrdude):

Maybe the operating system now has some service (or whatever)
that is immediately grabbing a TTY device once it appears?

Alas, I'm afraid that's nothing which can be solved in
AVRDUDE, rather a kind of OS issue.  At the very least, it
requires someone with more insight into OSX.

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?49376>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #49376] Resource busy error on El Capitan

Joerg Wunsch-6
Follow-up Comment #2, bug #49376 (project avrdude):

Indeed, as far as I know from Arduino-related forums (when investigating a
similar issue - cdc comms are also buggy in El Capitan -  I bumped into
complains that their environment/projects stopped working after upgrade to El
Capitan) - it turns out that starting 10.11 Apple somehow changed the way OSX
works with usb (enumerates usb?). Besides, they removed tty devices.
Do you mean to say that avrdude needs tty to work properly?
Anyway, I though there were some users of avrdude running El Capitan - wanted
to learn if they face such problem and their solutions...

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?49376>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Loading...