[bug #45095] Atmega328p fuses are not according datasheet

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #45095] Atmega328p fuses are not according datasheet

Joerg Wunsch-6
URL:
  <http://savannah.nongnu.org/bugs/?45095>

                 Summary: Atmega328p fuses are not according datasheet
                 Project: AVR Downloader/UploaDEr
            Submitted by: lja
            Submitted on: Qua 13 Mai 2015 09:43:21 GMT
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: lja
        Originator Email:
             Open/Closed: Open
         Discussion Lock: Any

    _______________________________________________________

Details:

This has nothing to do with the bug where the print was swapping hfuse and
efuse.

It looks that avrdude is swapping the extended fuse with the low fuse.

Dumping m328p fuses I get:

avrdude.exe: Device signature = 0x1e950f
avrdude.exe: safemode: lfuse reads as FF
avrdude.exe: safemode: hfuse reads as D1
avrdude.exe: safemode: efuse reads as 5


But in reality the 0xff is the efuse and 0x05 is the lfuse.

This can be confirmed in page 283 of the datasheet:
http://www.atmel.com/images/Atmel-8271-8-bit-AVR-Microcontroller-ATmega48A-48PA-88A-88PA-168A-168PA-328-328P_datasheet_Complete.pdf

It seems weird that nobody else noticed this... unless I'm missing something
here!




    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45095>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #45095] Atmega328p fuses are not according datasheet

Joerg Wunsch-6
Follow-up Comment #1, bug #45095 (project avrdude):

Hmmm, on a second look maybe it's ok.

This can be marked as invalid and closed...

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45095>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #45095] Atmega328p fuses are not according datasheet

Joerg Wunsch-6
Follow-up Comment #2, bug #45095 (project avrdude):

I see same problem with atmega328. Bug with swapping house and refuse.


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45095>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #45095] Atmega328p fuses are not according datasheet

Joerg Wunsch-6
Follow-up Comment #3, bug #45095 (project avrdude):

Sorry I mean swapping hfuse and efuse.


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45095>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #45095] Atmega328p fuses are not according datasheet

Joerg Wunsch-6
Update of bug #45095 (project avrdude):

                  Status:                    None => Duplicate              
             Open/Closed:                    Open => Closed                


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45095>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[bug #45095] Atmega328p fuses are not according datasheet

Joerg Wunsch-6
Additional Item Attachment, bug #45095 (project avrdude):

File name: Screenshot from 2017-03-22 22-47-35.png Size:29 KB


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45095>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Loading...