[bug #41388] ATxmega32c4 and ATxmega16c4 have wrong signatures

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #41388] ATxmega32c4 and ATxmega16c4 have wrong signatures

Joerg Wunsch-6
URL:
  <http://savannah.nongnu.org/bugs/?41388>

                 Summary: ATxmega32c4 and ATxmega16c4 have wrong signatures
                 Project: AVR Downloader/UploaDEr
            Submitted by: nibz
            Submitted on: Wed 29 Jan 2014 01:43:30 PM GMT
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: N Brulez
        Originator Email:
             Open/Closed: Open
         Discussion Lock: Any

    _______________________________________________________

Details:

In the current revision of avrdude.conf.in, the ATxmega32c4 and ATxmega16c4
have wrong signatures.

Current revision:
ATxmega32c4 --> 1E 94 43
ATxmega16c4 --> 1E 95 44

Where it should be the opposite:
ATxmega32c4 --> 1E 95 44
ATxmega16c4 --> 1E 94 43

Sources:
http://www.atmel.com/devices/ATxmega32C4.aspx
and specially page 14 of
http://www.atmel.com/Images/Atmel-8493-8-and-32-bit-AVR-XMEGA-Microcontrollers-ATxmega16C4-ATxmega32C4_Datasheet.pdf

Anyway, programming an ATxmega32c4 works well with '-p avrxmega32c4 -F'.




    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?41388>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|

[bug #41388] ATxmega32c4 and ATxmega16c4 have wrong signatures

Joerg Wunsch-6
Update of bug #41388 (project avrdude):

                  Status:                    None => Fixed                  
             Assigned to:                    None => joerg_wunsch          
             Open/Closed:                    Open => Closed                
                 Release:                    None => 6.3                    

    _______________________________________________________

Follow-up Comment #1:

Fixed in r1416 (patch #8910)

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?41388>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev