Please help on stk500_getsync() problem.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Please help on stk500_getsync() problem.

Lasse Karagiannis
Hi, using ATMEL studio 7, and I keep on getting this responce what ever I do

avrdude.exe: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
             Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
             Copyright (c) 2007-2009 Joerg Wunsch

             System wide configuration file is "C:\Program Files (x86)\Arduino\h
ardware\tools\avr\etc\avrdude.conf"

             Using Port                    : COM6
             Using Programmer              : arduino
             Overriding Baud Rate          : 57600
avrdude.exe: stk500_getsync() attempt 1 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 2 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 3 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 4 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 5 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 6 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 7 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 8 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 9 of 10: not in sync: resp=0x3f
avrdude.exe: stk500_getsync() attempt 10 of 10: not in sync: resp=0x3f

avrdude.exe done.  Thank you.

Press any key to continue . . .

I am using the following parameters:
Command:
C:\Program Files (x86)\Arduino\hardware\tools\avr\bin\avrdude.exe
Arguments:
-C "C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf" -v -v -p m32u4 -c arduino -P COM6 -b 57600 -U flash:w:"$(ProjectDir)Debug\$(ItemFileName).hex":i

Initial Directory:
$(ProjectDir)

Running Arduino Leornardo on ATMega32u4, my COM port is for Arduino Leornado is COM5, and my Arduino Leornado Bootloader
is on COM6.

Does anybody know and can help me out?

Kindest regards,

Lasse Karagiannis



_______________________________________________
AVR-chat mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avr-chat
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Please help on stk500_getsync() problem.

Erik Christiansen-2
On 23.10.15 07:42, Lasse Karagiannis wrote:
> avrdude.exe: stk500_getsync() attempt 1 of 10: not in sync: resp=0x3f
...

> Arguments:
> -C "C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf" -v
> -v -p m32u4 -c arduino -P COM6 -b 57600 -U
> flash:w:"$(ProjectDir)Debug\$(ItemFileName).hex":i
>
> Initial Directory:
> $(ProjectDir)
>
> Running Arduino Leornardo on ATMega32u4, my COM port is for Arduino
> Leornado is COM5, and my Arduino Leornado Bootloader
> is on COM6.

I haven't fiddled with the arduino toolchain, but instead blown away the
bootloader and just used the unit as a bare AVR development board with
avr-gcc, so haven't had that issue. However, it looks like arduino users
have found various ways to produce that type of error message:

http://www.instructables.com/id/A-solution-to-avrdude-stk500getsync-not-in-syn/

http://forum.arduino.cc/index.php?topic=28223.0

There are doubtless other google hits which describe causes and fixes,
and there are youtube clips on the subject - though they seem a tedious
way to fight your way to anything informative.

Your device seems to match, leaving correcting mismatched com ports,
pressing reset, and disconnecting RX, as potential fixes.

Good luck.

Erik

_______________________________________________
AVR-chat mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avr-chat
Loading...