AVRDUDE 5.11 is broken for AVRISPmkII/STK600 TPI handling

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

AVRDUDE 5.11 is broken for AVRISPmkII/STK600 TPI handling

Joerg Wunsch
Heads up: I just noticed the recent introduction of the bitbang TPI
implementation introduced a regression that lead to the AVRISPmkII and
STK600 programmers no longer being accepted for TPI devices (i.e., for
the ATtiny10).  There's also been another regression, in that the
USBasp TPI patch added page_size even for the minor memory regions of
ATtiny10 et al. (like fuses or signature) which the TPI code in
stk500v2.c was not prepared to handle.

I'll perhaps branch version 5.11 off, and roll an 5.11.1 release
with just the TPI fixes.

--
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|

Re: AVRDUDE 5.11 is broken for AVRISPmkII/STK600 TPI handling

Joerg Wunsch
As Joerg Wunsch wrote:

> I'll perhaps branch version 5.11 off, and roll an 5.11.1 release
> with just the TPI fixes.

I just uploaded an avrdude-5.11.1rc.tar.gz to savannah.  Please test
this!

I merged all the recent bugfixes from SVN trunk, notably the fixes for
the AT90S1200, and the fix for programming TPI devices (ATtiny10 et
al.) using an AVRISPmkII or STK600.

Not included (of course) is the memory-tagging mega-patch.
--
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|

Re: AVRDUDE 5.11 is broken for AVRISPmkII/STK600 TPI handling

Joerg Wunsch
As Joerg Wunsch wrote:

> > I'll perhaps branch version 5.11 off, and roll an 5.11.1 release
> > with just the TPI fixes.
>
> I just uploaded an avrdude-5.11.1rc.tar.gz to savannah.  Please test
> this!

I just released 5.11.1, and this time, also remembered to update
the documentation on the web page.
--
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev
Reply | Threaded
Open this post in threaded view
|

Re: AVRDUDE 5.11 is broken for AVRISPmkII/STK600 TPI handling

Darell Tan
Oops I'm sorry I overlooked that.

Thanks for fixing it!

--
Regards,
Darell Tan



On Fri, Sep 16, 2011 at 7:25 PM, Joerg Wunsch <[hidden email]> wrote:

> As Joerg Wunsch wrote:
>
> > > I'll perhaps branch version 5.11 off, and roll an 5.11.1 release
> > > with just the TPI fixes.
> >
> > I just uploaded an avrdude-5.11.1rc.tar.gz to savannah.  Please test
> > this!
>
> I just released 5.11.1, and this time, also remembered to update
> the documentation on the web page.
> --
> cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL
>
> http://www.sax.de/~joerg/                        NIC: JW11-RIPE
> Never trust an operating system you don't have sources for. ;-)
>
> _______________________________________________
> avrdude-dev mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/avrdude-dev
>
_______________________________________________
avrdude-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/avrdude-dev